Datafeeds link in article leads to 404

3 years 4 months ago #3957 by Jeroen

Hi Bram,

I wanted to show the feed inside an article. I used this code inside a Joomla article:

{component index.php?option=com_datafeeds&view=items&Itemid=679}

The Itemid is the id of a datafeed-menu. The feed seems to show correctly at first in the article, but the pagination doesn't. After every link for the next pages the following code is pasted: /start10.html&c0356689ca1b8ed67c441f8a35cd8995=bc3cfc8cc68bd72a57b7bff10a7b04c3

Without everyting after & the link works. But I can not get rid of it. Thought it was the "amp;"-part. But that didn't matter either.

How can I solve this? Any idea?



  • Posts: 7
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    3 years 4 months ago #3958 by bram

    The pagination should not be shown at all.


    as componentanywhere makes an internal request and adds &tmpl=component to the request. As a result the pagination should be omitted

    I worked with component anywhere in the past but there where some reasons I stopped using it (not sure why anymore, caching issues was one thing)


    adding a module ( loadposition) is a good method to add items to your tekst, i have a different method on some of my sites:

    see j3.gryla.biz/src-test

    in the tekst I have a simple url like

    <a class="loaddf" href=" j3.gryla.biz/Damen ">Alle Damen mode</a>

    and then a bit of javascript:

    $( document ).ready(function() {
    
    $('a.loaddf').each( function(  ) {
            target= $(this).attr('href');
            $(this).addClass('uk-button');
            a=$('<div style="clear:both"><div class="uk-container uk-text-center"><i class="uk-icon-justify uk-icon-spinner uk-icon-spin uk-icon-large"></i></div></div>');
            $(this).before(a);
            a.load(target + ' section#main',{ tmpl: "component",num:4 });
    
    
    });
    });
    
    
    });
    



  • Posts: 1494
  • Karma: 57
  • Thank you received: 247

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    3 years 4 months ago #3959 by Jeroen

    Hmmm, I will look at that. What's the "num:4" part?



  • Posts: 7
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    3 years 4 months ago #3960 by bram

    (You will need to adapt the javascriptide for your site. )

    The num limits the number of items. It over rules the setting in the menu configuration



  • Posts: 1494
  • Karma: 57
  • Thank you received: 247

  • Gender: Unknown
  • Birthdate: Unknown
  • The following user(s) said Thank You: Jeroen

    Please Log in to join the conversation.

    3 years 4 months ago #3961 by Jeroen

    Strange. Updated to the latest version of Joomla and the problem is gone. Must have been some Joomla-component bug. Thanks anyway!



  • Posts: 7
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    Time to create page: 0.053 seconds
    Powered by Kunena Forum