feedcron.php error

3 years 8 months ago #4017 by cool410

A-Feeder 3.1.2128 Joomla 3.4.4 .OS Linux.

Hi Bran
I have come up with another error that comes in the error_log in the /cron/
directory my cron is working I got the admin tech from my server to set up the cron job
My Data does update it's this Log file grows by 30mg every few days .

the error from the log is : about 41878 times every 2 day aprox

[18-Oct-2015 19:47:19 Europe/London] PHP Notice: Undefined offset: 1 in /home/a22cheap/public_html/administrator/components/com_datafeeds/cron/feeds.php on line 61
[18-Oct-2015 19:47:19 Europe/London] PHP Notice: Undefined offset: 2 in /home/a22cheap/public_html/administrator/components/com_datafeeds/cron/feeds.php on line 61
[18-Oct-2015 19:47:19 Europe/London] PHP Notice: Undefined offset: 1 in /home/a22cheap/public_html/administrator/components/com_datafeeds/cron/feeds.php on line 61
and so on ....

and the email conformation gives this error ;-

PHP Warning: 1 MagpieRSS: Failed to parse RSS file. (Cannot open ) in /home/a22cheap/public_html/administrator/components/com_datafeeds/cron/rss_fetch.inc on line 242
PHP Warning: Creating default object from empty value in /home/a22cheap/public_html/administrator/components/com_datafeeds/cron/xml_fetch.inc on line 82

I had a funny feeling it might be that I had 0 seconds in the Datafeeds Administrator section which seem to be the default which I never changed.
I have now set this to 24 hours . or do I some how have to sync this with the cron job time which is 0500 Monday to Friday . 0 5 * * 1-5

I did read though the other articles that had been published but they all did not mention the error_log and they had feed error or non update.
and most had the cron job wrong .

Is this just another small bug or time Sync problem ??



  • Posts: 23
  • Karma: 1
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    3 years 8 months ago #4018 by bram

    The notices are not errors but mere a sign of lazy coding.

    to improve speed the examples in feeds.php skip some checks, it will help to put the command below into your feeds.php, somewhere near the top below the <?php

    error_reporting(E_ERROR | E_WARNING | E_PARSE);

    the ' Failed to parse RSS file' means that the importer was not able to load the file specified as feed url in the feed configuration, but i can't get details from the messages posted


    the component does not automaticly activate cronjobs, you must do this either manualy or using a cronjob.

    The 'freq' field of the feed defines the minimal time between two updates. If this is set to 172800 or '2 Days' the feed will on be updated again after 2 days, even if you hit the 'update feeds' button twice on hour.

    Most of my fashion-feeds are set to 23 hours, and I have a cron once a day.

    For travel I update once a week, those change that often



  • Posts: 1494
  • Karma: 57
  • Thank you received: 247

  • Gender: Unknown
  • Birthdate: Unknown
  • The following user(s) said Thank You: cool410

    Please Log in to join the conversation.

    3 years 8 months ago #4019 by cool410

    Hi Bran
    I will do that . Thanks . Are there any more of these error I should know about
    to save bugging you every so often .

    I wont tell the others .. promise



  • Posts: 23
  • Karma: 1
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    3 years 8 months ago #4020 by bram

    I'm glad if people report problems.

    I thought I removed all warnings and notices from the main component, but you found some 'strict' warnings I missed.

    I general warnings and notices are not a direct problem but they should be looked after to avoid possible future problems. And sometimes they indicate a real fault like types in the array indices ( $item )

    As a side note: on a production server you should not run with the error level set to warnings and/or notices.

    cheers



  • Posts: 1494
  • Karma: 57
  • Thank you received: 247

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    3 years 8 months ago #4021 by cool410

    Hi thanks again.

    I have not changed the error setting I just check my error logs regularly
    as I did have someone trying to Hack my site.
    so I added clef Login to Joomla and it also fixes the login bug so you can
    also use Google Authorisation . The missing button to "Submit" verification

    Just info it works great have not seen a hacker or spam since installed.

    Thanks and keep up the great work .



  • Posts: 23
  • Karma: 1
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    Time to create page: 0.043 seconds
    Powered by Kunena Forum