sql_mode = ''

4 years 4 months ago #3795 by thesaint

Hi

I've been using Affiliatefeeds for a while and love it!

Im just trying to setup a new site on a different server, which all works well until I try to Import Data when I get the following message...


You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'sql_mode = ''' at line 1
SET @@SESSION sql_mode = ''



Everything else look as though it works ok it's just the Import that goes wrong. Any thoughts?



  • Posts: 2
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    4 years 4 months ago #3796 by bram

    typo, not many are using php-mysql any more so it remained unnoticed

    please check the file administrator/components/com_datafeeds/cron/mysql.php

    there is a line with SET @@SESSION sql_mode:
    either remove that line or remove the @@
    or add a dot between SESSION and sql

    corrected file svn.brambring.nl/svn/xmlstuff/datafeeds/...admin/cron/mysql.php



  • Posts: 1494
  • Karma: 57
  • Thank you received: 247

  • Gender: Unknown
  • Birthdate: Unknown
  • The following user(s) said Thank You: thesaint

    Please Log in to join the conversation.

    4 years 4 months ago #3797 by thesaint

    Great - Thanks for the quick and perfect reply.

    It's working great.



  • Posts: 2
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    Time to create page: 0.046 seconds
    Powered by Kunena Forum