items wont be inserted in the Database Tabbles

4 years 9 months ago #3554 by godfather

hi
when i add a feed and fetching it is evry thing ok and when i import the data it seems for the first ok and there is no errors.. but the items of the feed wont be added or inserted to the database tabbels.

i thought that the csv were empty. so i took a look in the csv-file and it wasnt empty.

and ive searched in the phpmyadmin for the feed which ive added .. but there is no results which means the feed hadnt been inserted to the table.

and while imoprting the feeds i looked in the process in the phpmyadmin and noticed a status "Am Ende der Abfrage automatisch ergänzter Backtick!" which i didnt understood. i dont know if that is the reason why the items wont be inserted to the table!!

my all feeds are affected whith this phenomena. so over 50% of the produkts were deleted so i stoped the import.

what could be the reason for that? and i cant find any solution for that :(..

thank u for any suggestion



  • Posts: 86
  • Karma: 1
  • Thank you received: 4

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    4 years 9 months ago #3556 by bram

    i might be an issue with 'unique' items.
    If several items have the same combination of title+Select0+Select1+...+Select19 only one of each will be imported.

    I have to check the backtick message, there aren't any known problems as far as I know.


    could you email me a link to the csv file?



  • Posts: 1494
  • Karma: 57
  • Thank you received: 247

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    4 years 9 months ago #3558 by godfather

    i sent u an email.. i forget to say am using for this site joomla 2.5 whith datafeed component for 2.5.

    ive sent u an email whith the link to the csv file.. as i noticed all the feeds are affected when i start to import them i have over 80 feeds and while importing i noticed how the produktsnumbers rapid goes down. so i cancled all imports (refreshing data).



  • Posts: 86
  • Karma: 1
  • Thank you received: 4

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    4 years 9 months ago #3559 by godfather

    ive contacted the server administrator and asked him if he had done any changes to the server. he said he did only some regular updates to the server (non big updates).

    i think it has somting to do whith server updates.. but the question is which values or parameters are responsible for this issue, that no items would be able to be inserted to the database items :S!!!



  • Posts: 86
  • Karma: 1
  • Thank you received: 4

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in to join the conversation.

    4 years 9 months ago - 4 years 9 months ago #3560 by bram

    Just a round up here:

    • some items are not unique by the definition of the parser ( title+Select1 etc. you can solve this by mapping a field like 'artnumber' to one of the Select fields or create a custom hash in an import filter :
      $item['md5']=md5($item['feed'].$item['artnumber']);
    • I can't reproduce the mysql message, even not in strict mode



  • Posts: 1494
  • Karma: 57
  • Thank you received: 247

  • Gender: Unknown
  • Birthdate: Unknown
  • Last Edit: 4 years 9 months ago by bram.
    The following user(s) said Thank You: godfather

    Please Log in to join the conversation.

    Time to create page: 0.050 seconds
    Powered by Kunena Forum