Feed import not working anymore due to time limit

7 years 6 months ago #4041 by lmattys
Hi, I was testing the feed importer and the first few times it worked fine bu now I keep getting an error message when importing a feed:
Warning: set_time_limit(): Cannot set max execution time limit due to system policy in /customers/3/6/8/mlmwarehouse.com/httpd.www/administrator/components/com_datafeeds/cron/feedcron.php on line 75
System load:20.85,35.78,39.45

Warning: Cannot modify header information - headers already sent by (output started at /customers/3/6/8/mlmwarehouse.com/httpd.www/administrator/components/com_datafeeds/cron/feedcron.php:215) in /customers/3/6/8/mlmwarehouse.com/httpd.www/administrator/components/com_datafeeds/cron/feedcron.php on line 236
Server too busy(Load: 20.85 Max: 10). Please try again later. help
Cleanup of unpublised feed items : 0.000 delta: 1448309066.976
0 items in database : 0.001 delta: 0.001
0 items in database : 0.002 delta: 0.001
Clean End : 0.002 delta: 0.000
Table: z4jun_dataitems Free Size: 3720032
System load:20.85,35.78,39.45

Nothing has changed since the first few times so I don't understand what is going wrong now. Is it the importer or the hosting provieder?

Please Log in or Create an account to join the conversation.

7 years 6 months ago #4042 by bram
I see two distinct issues:

Most webservers have a restriction on the time a php-script may execute, that's to protest the server. If you are working with a lot of feeds and/or large feeds you will reach the limit. On some servers it is allowed to extend
the limit using set_time_limit, on yours it is not.

high load:
The feed import might take a lot of resources, as a basic protection the script will check the system load. By default it is set to 10, for must server a system load of 10 is pretty high, however on other servers, with a lot of CPU's a higher limit might be acceptable. However you wouldn't be the first one with a disabled website by the hosting.

If you are running the import from the administrator tab the import will simply stop if the load is to high, if you are running the feedcron.php directly the script will wait untill the load drops ( or the time limit is reached)

From what I see you are not reaching the time limit, but the script simply stops because of the high load. (and you probable didn't notice the warning before)

You can override the default settings in your feeds.php see : affiliatefeeds.nl/en/217-load-protection.html
The following user(s) said Thank You: lmattys

Please Log in or Create an account to join the conversation.

7 years 6 months ago #4043 by lmattys
Hoi Bram, bedankt voor de snelle reactie. Ik heb contact opgenomen met de hostingprovider maar die begrijpen het verhaal niet helemaal. Ze weten bvb niet waar het getal "10" in het script voor staat en vragen of dit mb per sec. Zijn. Hoewel ikuitgelegd heb dat het over een script in mijn joomla systeem gaat denken zij dat ik het php.ini bedtand wil aanpassen, wat niet kan bij one.com. Ik wilde gewoon weten tot welke waarde ik evt. Mag verhogen. De gebruikte server is er een met 1 cpu dus dat geeft wel beperkingen.

Please Log in or Create an account to join the conversation.

Time to create page: 0.247 seconds