× If you report a bug please specify the joomla and component version.

normal Sitemap not working

8 years 9 months ago #1770 by sakattack
Sitemap not working was created by sakattack
Hello

My google sitemap shows only the 1 joomla menu item and nothing else.

That joomla menu has 6 levels in it, isn't the sitemap supposed to show links for all valid combinations of those 6 levels? Or have I misunderstood it and i'm supposed to make a joomla menu item for every single entry of all 6 levels?

Please help


  • Posts: 42
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in or Create an account to join the conversation.

    8 years 9 months ago #1771 by bram
    Replied by bram on topic Re: Sitemap not working
    What sitemap are you referring to? The build in sitemap of the datafeeds component or an external component like xmap?


  • Posts: 1421
  • Thank you received: 234

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in or Create an account to join the conversation.

    8 years 9 months ago - 8 years 9 months ago #1774 by sakattack
    Replied by sakattack on topic Re: Sitemap not working
    The built-in sitemap. I haven't been able to find an external component to provide a sitemap for datafeeds component. And I also mean the sitemap page, not the sitemapS one.


  • Posts: 42
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Last edit: 8 years 9 months ago by sakattack.

    Please Log in or Create an account to join the conversation.

    8 years 9 months ago #1775 by bram
    Replied by bram on topic Re: Sitemap not working
    I tried the sitemap on the latest version

    sitemap of sitemaps

    demos.affiliatefeeds.nl/shop/index.php?o...=items&format=xmlmap

    sitemap

    demos.affiliatefeeds.nl/shop/?format=xmlmap

    works fine. Did you set the xmap depth in the menu configuration?


  • Posts: 1421
  • Thank you received: 234

  • Gender: Unknown
  • Birthdate: Unknown
  • Please Log in or Create an account to join the conversation.

    8 years 9 months ago - 8 years 8 months ago #1776 by sakattack
    Replied by sakattack on topic Re: Sitemap not working
    Yes, I put it to depth 6, as many as my levels are. But no sitemap. Maybe i should mention that i also use sh404 to provide sef urls for the datafeeds component and it works excellently with it. However i don't see how that could be a problem for the sitemap generation.

    I'm submiting screenshots of my menu configuration and a link to the shop section and to the sitemap





    screenshots shows depth->5 but only because i was trying things out and forgot to switch it back to 6


  • Posts: 42
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Last edit: 8 years 8 months ago by sakattack.

    Please Log in or Create an account to join the conversation.

    8 years 9 months ago - 8 years 9 months ago #1777 by bram
    Replied by bram on topic Re: Sitemap not working
    disable sef404 to test.

    sef404 does not understand the structure of the datafeeds 'shop'

    using sef404 ( or any other sef external component) is not supported. To much hasle


  • Posts: 1421
  • Thank you received: 234

  • Gender: Unknown
  • Birthdate: Unknown
  • Last edit: 8 years 9 months ago by bram.

    Please Log in or Create an account to join the conversation.

    Time to create page: 0.089 seconds